eID na Ubuntu 19.10

Ma niekto skusenost s instalacou eID na LInux Ubuntu 19.10, instalacia nezbehne
Dependency is not satisfiable: sni-qt

3 Likes

Ani mne to nejde. Rovnaký problém. Našiel som na nete, že problém nastal tým, že qt4 dosiahol end of life, a tak ho dali preč z ubuntu. sni-qt je založený na qt4 knižniciach. Riešenie som zatiaľ nenašiel.

sni-qt je iba prvá dependency, ktorú systém nájde ako chýbajúcu, no je to vlastne iba vrchol ľadovca. Keďže eID je založená na qt4, tak na ubuntu 19.10 ani na novších verziách nepôjde. Tvorcovia ju budú musieť kompletne prepísať do qt5 (ktorý vyšiel v roku 2012), alebo podpora na linuxoch už nebude.

Viac napríklad tu: https://askubuntu.com/questions/1193152/how-to-install-sni-qt-in-ubuntu-19-10/1193155

1 Like

Chybu a návrh možných riešeni (port na qt5 alebo distribuovanie balíka ako snap či flatpak) som poslal na NASES.

Dostal som odpoveď z podpory na MinV (v NASES ma odkázali na nich)

Ubuntu 19.10 nie je medzi podporovanými linux-ovými platformami, pretože nie je vo verzii LTS. Preto je posledne podporované ubuntu 18.04. Ďakujeme za podnet ale aktuálne už finišujeme s upgradom Aplikácie pre eID na QT5 pre všetky podporované platformy Linux-u. Dátum zverejnenia novej verzie aplikácie zatiaľ nebol stanovený, ale musí to byť skôr ako 23.4.2020. Vtedy totiž vyjde Ubuntu 20.04 a tam je už prechod na QT5 nevyhnutný.

Čiže už pracujú na verzii pre QT5, ktorú chcú vydať pred koncom apríla. Potom by mal byť na čas opäť pokoj.

Alebo aj nie :frowning: Nemá niekto náhradné riešenie?

Ach… ja som nakoniec podával priznania ešte v marci, inak eID velmi nepoužívam. A keď, tak si požičiam manželkin notebook, kde je este dualboot. Toto je mrzuté.

Napísal som im doplňujúcu otázku.

Náhradné riešenie som zatiaľ nenašiel (dualboot nieje riešenie)

Je už k dispozícii verzia pre 20.04? Nevie niekto? Na portali je stale len stara verzia.

1 Like

Odpoved z MVSR (vyskusame uvidime):
Preposielame Vám stanovisko riešiteľov: Bola pripravená nová verzia Aplikácie pre eID pre Linux. Nová verzia sa nebude občanom aktualizovať automaticky. Je to totiž beta verzia. Verzia rieši upgrade používaného frameworku z QT4 na QT5. Pre Windows toto bolo vyriešené už v minulosti. Nie sú tam žiadne nové funkcionality alebo zmeny. Upozorňujeme však ešte raz, že je to len beta verzia a sprístupnenie finálnej verzie bude naplánované po skončení mimoriadnej situácie ohľadom ochorenia COVID-19.
Linky na aplikáciu:
64bit:
Debian https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_amd64_debian.tar.gz,
Mint https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_amd64_mint.tar.gz,
Ubuntu https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_amd64_ubuntu.tar.gz;

32bit:
Debian https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_i386_debian.tar.gz,
Mint https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_i386_mint.tar.gz,
Ubuntu https://eacmw.minv.sk/podpora/20200424/Aplikacia_pre_eID_i386_ubuntu.tar.gz.

Prosíme spätnú väzbu zasielajte len na e-mail: " callcentrum@minv.sk “. Ďakujeme za Vašu spoluprácu.

1 Like

funguje, teda aspon prihlasovanie

1 Like

Beta verzia funguje na prihlasovanie, ale v Ubuntu 20.04 nejde použiť na podpísanie opatrení :frowning:

Nerobil si to nahodou v chromium? Lebo mne to nejde tiez, ale tento kuzelny navod pomohol to rozbehat aspon vo Firefoxe.

Najľahšie dočasné riešenie by bolo stiahnuť sni-qt priamo odtiaľto: https://packages.ubuntu.com/bionic/sni-qt.

Pripadne nainštalovať predchádzajúcu verziu eID klienta, ktorá túto závislosť nemá.